View unanswered posts
View active topics
It is currently Thu Jan 23, 2020 12:34 am


*  Forum rules
Dear users,
we are sorry to inform you, that we had to end development of our FurryBall after almost ten years!
We will give FurryBall for free to all users, but without any Maintenace and Support.
Because we have to keep our servers working, we have set the symbolic price 29,- EUR per year.
Hope you will understand us and keep using FurryBall if it fits you.
Thanks for all those nice years with GPU rendering.
Your FurryBall team

Author Message
schmiddl
Post  Post subject: Viewport renders fine, final render black or artifacts  |  Posted: Thu Apr 28, 2016 12:38 pm

Joined: Tue Mar 18, 2014 5:20 pm
Posts: 56

Offline
Hi,
here is a screenshot of a furryball viewport rendering of a maya scene with only a white backdrop geometry:
Image

This is what happens when I render it in the maya render view with the same furryball render node:
Image

The scene featured several semi transparent objects before and was working perfectly fine (for this test I deleted all the objects besides the background geometry).
But after I cleared the furryball memory and texture cache, the renderings in the maya viewport always came out black. Remember that the furryball viewport render still shows the correct result!

So I deleted the objects to keep only the background. Then the images were not black anymore, but always render in the black and white pattern you can see above.
I tried restarting Maya and Furryball. I also tried restarting the computer, but this does not change anything.
The Maya render view says that Furryball uses about 470 mb gpu memory (of my titan black). Primary rays are set to 5, ray counts are set to 5, too.
There are no error messages in the maya output window. The scene is attached to this message.
Attachment:
ray_depth_test_only_bg.mb [197.84 KiB]
Downloaded 277 times


Top
Jan_Smejkal
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Thu Apr 28, 2016 12:58 pm
User avatar

Joined: Fri Aug 13, 2010 10:30 am
Posts: 794

Offline
Hi,
it is probably same issue as here: viewtopic.php?f=35&t=5256
This bug appeared in version 1.3.3905 and it is fixed in latest version of FurryBall.

In your case is solution simple - set other than primary rays (ie. Diffuse, Specular etc.) to 1. If you want to boost quality, use primary rays (see our documentation).


Top
schmiddl
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Thu Apr 28, 2016 1:29 pm

Joined: Tue Mar 18, 2014 5:20 pm
Posts: 56

Offline
Yes, setting everything but primary rays to 1 fixes it, thank you!

Too bad I can't use the ray counts feature, because my maintenance has run out.
When I paid for my Furryball upgrade from 4.8 to RT less than two months ago
I didn't expect I would have to pay another 199 Euro to get everything working. :(


Top
Jan_Tomanek
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Thu Apr 28, 2016 3:23 pm
User avatar

Joined: Tue Oct 27, 2009 11:03 pm
Posts: 1607
Location: Prague - Czech republic

Offline
Sorry for that - in case you don't want buy maintenance in the future and have always actual version, you can downgrade to older 1.2 version, where this bug is not present.
But this is not "30% faster version" :(

_________________
Thank you for contacting us.
If you have any further questions, please do not hesitate to contact us.

All the Best
Jan


Top
schmiddl
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Thu Apr 28, 2016 4:32 pm

Joined: Tue Mar 18, 2014 5:20 pm
Posts: 56

Offline
Dear Jan,
on the Furryball maintenance website (http://furryball.aaa-studio.eu/products/index.html#Maintenance)
you quote a sentence that I wrote almost two years ago in the Furryball forum: "Your support is one of the great assets
of Furryball and makes it stand apart from any renderer I've used! Thanks a lot for your fast replies and immediate bugfixes!!"
Here is the link to my post from May 28, 2014: http://aaa-studio.cz/furryballforum/viewtopic.php?f=25&t=4496&p=9548&hilit=Thanks+a+lot+for+your+fast+replies+and+immediate+bugfixes%21%21#p9548.

I remember writing it, because I kept on finding many bugs in Furryball 4.8 that you fixed very fast.
Without these fast fixes there was no way I could have finished the film production in Furryball 4.8!
At the time I had to invest a great amount of time to find which setting or geometry made problems
and I think your subsequent bug fixes made Furryball more stable and thus a better renderer.
Here is a link to the film from back then (completely rendered in Furryball 4.8): https://www.youtube.com/watch?v=Re3GN6udsd4

In the mean time since then I switched back to Mental Ray, but I think the Furryball RT upgrade is a
great product and it would be great if I could do more work with it.
So with all that said it would be nice if you would give me only the update for free that gets rid of the bug that I described above.
I'll happily buy an upgrade in a year, but with my history with Furryball it feels bad to buy RT, stumble on a bug in the first 48 hours of testing it
and having to spend 200 Euro to make it actually work. I hope you feel what I mean. And I still think your support is the best :) !


Top
Jan_Tomanek
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Thu Apr 28, 2016 5:20 pm
User avatar

Joined: Tue Oct 27, 2009 11:03 pm
Posts: 1607
Location: Prague - Czech republic

Offline
Dear Martin,

thanks for nice words about support and you great animation - we never see it BTW.

This money for Maintenance is why we can have this nice support and fast development, but it cost something unfortunately. In those days are softwares very cheap (in the beginning of FurryBall the license cost 2.000,- EUR...). For this money you can have one year support in the price, but when FurryBall (and other softwares) now cost under 400,- EUR, you can't expect you will have free upgrades forever... ;)

I'm not sure about what 48 hour you are talking. When you bought license you had 1 month Maintenace included for free.
I see you upgraded to RT on date 1/3/2016 - so your maintenance works until 1/4/2016 so you can use ALL RT versions until this date: http://furryball.aaa-studio.eu/aboutFur ... Notes.html

Unfortunately there was BIG update to much faster version 1.3 on the end of your Maintenance period, but in fact you bought version 1.2 and there are NO BUGS at all.
So as I wrote you, you can install older version 1.2 and there are no bugs and all is working.

Believe me, that almost the same problems have all other users. Imagine, that some COOL update come just one day after your year Maintenace expires... it's totally the same.

_________________
Thank you for contacting us.
If you have any further questions, please do not hesitate to contact us.

All the Best
Jan


Top
schmiddl
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Fri Apr 29, 2016 10:24 am

Joined: Tue Mar 18, 2014 5:20 pm
Posts: 56

Offline
Hi Jan,
I understand that a good product with great support has its price!

The production of the short film I mentioned above took at least a month longer,
because of the Furryball 4.8 bugs (and without your fast fixes would have taken
even longer) and we went well over budget because of that.
It was hard on our nerves, because we never knew if a bug could be found at
all or how long it would take to fix it.
So I feel like I've paid my fair share to be entitled to one RT bug fix update.
Can you see why I feel that way?

Of course everything you wrote above is true and under different circumstances
I'd happily pay for a great update!


Top
Jan_Tomanek
Post  Post subject: Re: Viewport renders fine, final render black or artifacts  |  Posted: Fri Apr 29, 2016 6:50 pm
User avatar

Joined: Tue Oct 27, 2009 11:03 pm
Posts: 1607
Location: Prague - Czech republic

Offline
BTW, I looked on your channel Filmbilder - Nice works - Is there anything made in FurryBall?
Send us by our credit system and we will give you free credit and you will be able use latest 1.3 by credit system. http://furryball.aaa-studio.eu/account/credit/

_________________
Thank you for contacting us.
If you have any further questions, please do not hesitate to contact us.

All the Best
Jan


Top
Display posts from previous:  Sort by  
Print view

Who is online
Users browsing this forum: No registered users and 7 guests
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
Jump to:   
cron

Delete all board cookies | The team | All times are UTC + 1 hour [ DST ]

Powered by phpBB® Forum Software © phpBB Group
DAJ Glass 2 template created by Dustin Baccetti